Posting issues [Update 10] -- Fixed

Announcements from The Changing Mirror's administrators.

Posting issues [Update 10] -- Fixed

Postby TheoW » Wed Jul 17, 2013 6:01 pm

There seems to be an ongoing problem with posting for some users, and I'm trying to track it down. I'm not sure what is going on, but when posting you might see:

Forbidden

You don't have permission to access /phpbb/posting.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


This is coming from the server, and for the moment I have no idea what is going on. I'm checking the logs and trying to find it, and hopefully I can, but I don't know the cause. This is an error from the server, not the forum, so modifying your post probably won't fix the issue.

Of course none of this is happening to ME, so it makes it harder to track down. Hate this sort of Heisenberg error.
Pretends to be the boss around here.

If you like like site, you can support it through my Ko-Fi page. I also have a Pateron for my writing.
User avatar
TheoW
Boss Lion
 
Posts: 542
Joined: Tue May 22, 2012 10:26 pm
Location: Third star to the left

Re: Posting issues

Postby TheoW » Wed Jul 17, 2013 6:15 pm

Okay, looking over the error log I've found what looks like a related issue that might be the cause. I've opened up a ticket with the hosting service, so cross fingers on a quick fix.

It would be easier of the log wasn't limited to 300 errors and every browsers requests a the missing favorite icon for the site which clutters up everything. Maybe I should have a logo/icon contest. :)
Pretends to be the boss around here.

If you like like site, you can support it through my Ko-Fi page. I also have a Pateron for my writing.
User avatar
TheoW
Boss Lion
 
Posts: 542
Joined: Tue May 22, 2012 10:26 pm
Location: Third star to the left

Re: Posting issues

Postby TheoW » Wed Jul 17, 2013 9:33 pm

I think we have the answer, now I'm working on the fix.

The answer... we're a bit to popular for the hostage package I have. I have the basic one the service offers and we are starting to hit the virtual memory limit on the host. When that happens PHP fails and pages die. I'm looking to upgrade the site to the higher package and see if that fixes the issue. If night I might have to go up from a shared host to a dedicated server.
Pretends to be the boss around here.

If you like like site, you can support it through my Ko-Fi page. I also have a Pateron for my writing.
User avatar
TheoW
Boss Lion
 
Posts: 542
Joined: Tue May 22, 2012 10:26 pm
Location: Third star to the left

Re: Posting issues [Update 3]

Postby TheoW » Thu Jul 18, 2013 10:14 pm

Update 3: Okay, so I've now upgraded the hosting package for the site, though it might take a couple days for everything to fall into place. Hopefully that will help with the load though I'm still trying to find what's causing us to have the memory usage spikes. Oh, and for the time being attachments are disabled, it seems like the memory issues might be related to that.

Now... if this doesn't fix it I'm going to have to upgrade to the next tier of service... though I'm tempted to just say to hell with it and go with the top of the line tier. It's a heck of a lot more pricey but it gives me full control.

Still, we've apparently gotten fairly popular, so I guess that's a plus. I wonder how we rank against the old site?
Pretends to be the boss around here.

If you like like site, you can support it through my Ko-Fi page. I also have a Pateron for my writing.
User avatar
TheoW
Boss Lion
 
Posts: 542
Joined: Tue May 22, 2012 10:26 pm
Location: Third star to the left

Re: Posting issues [Update 3]

Postby TheoW » Fri Jul 26, 2013 7:34 pm

Update 4: Well from the look of it, the upgrades didn't help that much. I'm going to have to talk with the hosting company to see if there is someway to raise the limits without having to go to the highest tier (which also has a high jump in price).

I really wish i knew why we were running out of memory now, I don't seem to have the tools to really track it down to more then just PHP... but everything on the site is PHP! It doesn't help :)
Pretends to be the boss around here.

If you like like site, you can support it through my Ko-Fi page. I also have a Pateron for my writing.
User avatar
TheoW
Boss Lion
 
Posts: 542
Joined: Tue May 22, 2012 10:26 pm
Location: Third star to the left

Re: Posting issues [Update 4] -- Still not fixed

Postby TheoW » Fri Jul 26, 2013 8:33 pm

For the time being I've disabled the webchat to see if it's what is causing the load issues.
Pretends to be the boss around here.

If you like like site, you can support it through my Ko-Fi page. I also have a Pateron for my writing.
User avatar
TheoW
Boss Lion
 
Posts: 542
Joined: Tue May 22, 2012 10:26 pm
Location: Third star to the left

Re: Posting issues [Update 5] -- Maybe Fixed?

Postby TheoW » Mon Jul 29, 2013 11:08 pm

Okay, we've gotten some tweaks done on the server, and from my side it's looking like it should be stable now but I can't tell directly. You guys are going to have to let me know if it's working or not. Hopefully it is!
Pretends to be the boss around here.

If you like like site, you can support it through my Ko-Fi page. I also have a Pateron for my writing.
User avatar
TheoW
Boss Lion
 
Posts: 542
Joined: Tue May 22, 2012 10:26 pm
Location: Third star to the left

Re: Posting issues [Update 5] -- Maybe Fixed?

Postby sysop » Thu Aug 01, 2013 6:24 am

Sorry Theo. I just received the same error when trying to update one of my chapters. Thanks for the hard work trying to troubleshoot.
sysop
Member
 
Posts: 44
Joined: Mon Oct 01, 2012 7:27 am

Re: Posting issues [Update 5] -- Maybe Fixed?

Postby TheoW » Fri Aug 02, 2013 6:45 pm

I'll keep going, it looks like the errors should be irregular now...
Pretends to be the boss around here.

If you like like site, you can support it through my Ko-Fi page. I also have a Pateron for my writing.
User avatar
TheoW
Boss Lion
 
Posts: 542
Joined: Tue May 22, 2012 10:26 pm
Location: Third star to the left

Re: Posting issues [Update 6] -- Chat is Back!

Postby TheoW » Sun Aug 04, 2013 9:14 am

The web chat is back up :)
Pretends to be the boss around here.

If you like like site, you can support it through my Ko-Fi page. I also have a Pateron for my writing.
User avatar
TheoW
Boss Lion
 
Posts: 542
Joined: Tue May 22, 2012 10:26 pm
Location: Third star to the left

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest